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Lab 1: Introduction to QGIS 
 

1.1. Objectives 
 

- Introduce QGIS software. 

- Install QGIS and review its interface 
 

1.2. Theory 
 

QGIS 
 

QGIS (Quantum GIS) is a free and open-source geographic information system (GIS) 

software that allows users to create, edit, visualize, analyze, and publish geospatial 

information. 

 
Features 

 

i. Versatility: Supports various vector, raster, and database formats. 

ii. Plugins: Extensive plugin architecture for customization and extending 

functionality. 

iii. Interoperability: Compatible with other GIS software and data formats. 

iv. Data Analysis: Offers a wide range of spatial analysis tools. 

v. Mapping: Capable of creating high-quality maps with advanced cartographic 

features. 

 

Pros 
 

→ Free and open-source. 

→ Cross-platform compatibility. 

→ Extensive functionality and customization options. 

→ Active development and community support. 

→ Scalable for both small and large projects. 
 

Cons 
 

→ Steeper learning curve compared to some commercial GIS software. 

→ Occasional stability issues, especially with complex operations or large datasets. 

→ Limited technical support compared to commercial alternatives. 
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Output 
 

1. Loading QGIS software after installation. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Interface of QGIS software. 
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Lab 2: Creating and Managing Vector Data 
 

2.1. Objectives 
 

- Adding vector layer (do for Gwarko city) 

- Setting properties and formatting 
 

2.2. Theory 
 

Layer 
 

→ A layer is a fundamental component used to display and work with geographic data. 

→ Layer can represent various types of data, including vector data and raster data. 

→ Each layer in QGIS is associated with a specific dataset, which can be stored in 

various formats such as shapefiles, GeoJSON, or spatial databases like PostgreSQL. 
 

Steps to Create a New Shapefile Layer 
 
1. Launch the QGIS software. 

2. In the menu bar, click on the "Layer" → Create Layer → New Shapefile Layer. 

3. Choose the type of geometry for your layer. 

4. Select the appropriate CRS (Coordinate Reference System) for your data. 

5. Define the attributes (fields) for your layer, including their names and data types. 

6. Enter a name for your shapefile and choose the directory where you want to save it. 

7. Click the pencil icon to add, modify, or delete features as needed. 
 

2.3. Output 
 

1. Creating new shapefile layer 
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Lab 3: Calculating Area Statistics of Vector Data 
 

3.1. Objectives 
 

- Load the map of Nepal as vector map and calculate the area of gaunpalika or 

municipality 

 

3.2. Theory 
 

Vector Layers 
 

A vector layer in QGIS is a type of data representation used to store geographic features 

like points, lines, or polygons, using vector data. It can contain points, lines, or polygons, 

each defined by coordinates and attributes. It is essential for handling spatial data in GIS 

projects, allowing users to visualize, analyze, and manipulate geographical information. 

 

Steps for adding vector layer and calculating the area of gaunpalika or municipality 
 

1. Launch the QGIS software. 

2. Go to the "Layer" menu in the menu bar. 

3. Select "Add Layer" → "Add Vector Layer" or simply use the "Add Vector Layer" 

button in the toolbar. 

4. Browse to the location of your vector data file. 

5. Select the file and click "Open" to add it to the map canvas. 

6. After adding the vector layer, right-click on the layer name in the Layers panel and 

select "Open Attribute Table". 

7. Click on the "Field Calculator" button located within the "Attribute Table" window. 

• Create a new field, name it appropriately, and specify its data type. 

• In the expression box, type `$area` to calculate the area of each polygon feature. 

• Click "OK" to apply the changes. 

8. Once the area field is added, the area values will be automatically calculated for each 

district polygon. 

 
Steps to calculate basic statistics 

 

In QGIS, you can calculate basic statistics for fields, which helps to quickly calculate and 

analyze basic descriptive statistics for attribute fields within vector layers. This tool helps 

to quickly figure out some key facts and figures about the categories in your map, making 

it easier to understand and work with your data. Here's how to use it: 
 

1. Navigate to the "Vector" menu and select "Analysis Tools". 

2. Choose the submenu "Basic Statistics for Fields". 

3. Select the layer containing the attribute table you want to analyze. 

4. Choose the specific field for which you want to calculate basic statistics. 

5. Browse to the destination where you want to save the results. 

6. Press "Run". 
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3.3. Output 
 

1. Added a vector layer local_unit.shp - Map of Nepal. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

2. Attribute Table of the vector layer.  
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3. Using 'Field Calculator' to create and add a new filed to the attribute table. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. 'Area' field successfully added in the Attribute Table. 
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5. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Calculating basic statistics for Area field. 
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7. Output HTML file generated after calculating field statistics on area. 
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Lab 4: Exploring and Managing Raster Layer 
 

4.1. Objectives 
 

- Adding raster layer, and setting properties and formatting it. 

- ADD two raster layer file (population of world in 1990 and 2000) then calculate 

change in population in 10 years also do the formatting. 

 

4.2. Theory 
 

Raster Layer 
 

A raster layer refers to a digital image or map composed of a grid of cells or pixels, each 

cell containing a value representing a certain attribute. Raster layers are commonly used to 

represent continuous phenomena across a geographic area, such as terrain, vegetation, or 

satellite imagery. 

 
A raster layer is a grid-based representation of imagery or gridded data, like satellite images 

or elevation models. It is used for tasks such as land cover analysis, terrain modeling, and 

environmental monitoring, offering tools for visualization and analysis within the software. 

The grid of cells contains values representing certain attributes. 

 
Raster Calculation 

 

Raster calculation is the process of performing mathematical operations on raster data 

layers in QGIS. It enables users to derive new information, conduct spatial modeling, and 

make informed decisions based on spatial data. 

 

Steps to add Raster Layers in QGIS 
 

Ensure you have the raster dataset you want to add saved in a compatible format. 
 

1. Launch the QGIS software. 

2. Go to the "Layer" menu in the menu bar then select "Add Layer" → Add Raster Layer. 

3. In the "Data Source Manager" window that appears, navigate to the location of your 

raster dataset. 

4. Select the raster file you want to add from the file browser and click "Open". 

5. The raster layer will appear in the "Layers Panel" on the left side of the QGIS interface, 

and the layer will be displayed in the main map canvas. 

 

Raster Calculation 
 

Raster calculation involves performing mathematical operations on raster layers to derive 

new information or analyze relationships between variables. This process allows users to 

generate new raster layers based on the values of one or more input raster layers. 
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Steps to Perform Raster Calculation 
 

1. Launch the QGIS software on your computer. 

2. Ensure that the raster layers are loaded using the steps outlined earlier. 

3. Go to the "Raster" menu in the menu bar at the top of the QGIS interface and select 

"Raster Calculator". 

4. Define a mathematical expression that specifies the desired calculation. 

5. Specify the name and location for the output raster layer that will be created as a result 

of the calculation. 

6. Once the expression is defined, click the "OK" button to execute the calculation. 

7. After the calculation is completed, the output raster layer will be added to the QGIS 

project. You can visualize the result, adjust its symbology, and perform further analysis 

as needed. 

 

4.3. Output 
 

1. Added two raster layers (.asc files) representing the world population in 1990 and 2000. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Using 'Raster Calculator' to calculate the change in population between 1990 and 2000. 
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3. Setting/formatting properties of the resultant layer representing change in population. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Resultant Output: 
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Lab 5: Importing Spreadsheets or CSV files 
 

5.1. Objectives 
 

- Import and work with CSV files and other tabular data in a GIS project. 
 

5.2. Theory 
 

CSV File 
 

A Comma Separated Values (CSV) file is a plain text file that stores data by delimiting data 

entries with commas. It is used to store tabular data, where each line represents a row, and 

each value within a row is separated by a comma. CSV files are often used when data needs 

to be compatible with different programs. 

 
CSV file is commonly used for storing and exchanging data between different software 

applications, as it is simple and widely supported. CSV files are often used for tasks such 

as data import/export, data manipulation, and data analysis. 

 

Delimited Text Layer 
 

A delimited text layer refers to a vector layer created from tabular data stored in a delimited 

text file, such as a CSV file. This type of layer allows us to visualize and analyze point, 

line, or polygon features based on the geographic coordinates and attributes provided in the 

text file. Delimited text layers are useful for importing and displaying non-spatial data in a 

GIS environment. 

 
In delimited text layer, values are separated by a delimiter such as a comma, tab, semicolon, 

or space. This text file could be in CSV format or any other delimited format. 

 

Steps to Use Delimited Text Layer 
 

1. In QGIS, go to the "Layer" menu in the menu bar. 

2. Select "Add Layer" → Add Delimited Text Layer. 

3. Browse to the location of your delimited text file. 

4. QGIS will automatically detect the delimiter used in the text file. You may need to 

adjust the settings if necessary, such as choosing the correct coordinate reference 

system and specifying which columns contain the latitude and longitude values. 

5. Once you have specified the parameters, click "Add" to create the delimited text layer 

in the QGIS project. 

6. The delimited text layer will be added to the Layers Panel. 
 

Plugins 
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Plugins are additional tools or functionalities that extend the capabilities of the software 

beyond its core features. Plugins are developed by independent organizations and 

developers. The QGIS organization does not take any responsibility for them. 

 

Steps to Use Plugins 
 

1. Go to the "Plugins" menu in QGIS. 

2. Browse through the list of available plugins. 

3. Search for the plugin you want to install and press "Install". 
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5.3. Output 
 

1. Add required delimited text layer (Cities_Asia.csv & Earthquake.csv). 
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2. Delimited text layers with their attribute table. 
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3. Install required plugin for OMS. 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 

4. Added OpenStreetMap (OSM) data using XYZ Tiles. 
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5. Showing city points 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
6. Showing earthquake points 
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Lab 6: Creating Map 
 

6.1. Objectives 
 

- Learn how to create map compositions using the Print Layout functionality. 

- Add and arrange map elements, then export the final layout as a PDF or image file. 
 

6.2. Theory 
 

Print Layout 
 

→ The Print Layout functionality in QGIS allows users to create professional-quality 

map compositions for printing or exporting. 

→ It provides a versatile environment for arranging map elements such as maps, 

legends, scale bars, north arrows, and text labels into a single document. 

 

Steps to Use Print Layouts in QGIS 
 

1. Go to the "Project" menu in the menu bar and select "New Print Layout" or click 

the "New Print Layout" button on the toolbar. This opens the Print Layout Manager. 

2. To add a map to the layout, click the "Add Map" button in the toolbar or drag the 

map item from the Layout toolbox onto the canvas. Resize and reposition the map 

as desired. 

3. Use the Layout toolbox to add additional map elements such as legends, scale bars, 

labels, and images. Drag these items onto the canvas and customize their properties 

using the Item Properties panel. 

4. Arrange the map elements on the canvas and adjust their styles. 

5. Once the layout is finalized, go to the "Layout" menu and select "Export as PDF" 

or "Export as Image" to save the layout as a PDF file or image file. 
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6.3. Output 
 

1. Added three vector layers: natural.shp, waterways.shp and roads.shp. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Creating new print layout. 
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3. . 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Adding map to the print layout. 
 
 
 
 
 
 
 
 
 
 
 

5. Map of Koshi Province with appropriate map decorations and layout items. 
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Lab 7: Projection 
 

7.1. Objectives 
 

- Understand the importance of projections in GIS. 

- Learn how to transform geographic data from one Coordinate Reference System 

(CRS) to another in QGIS. 

 

7.2. Theory 
 

Projections 
 

→ Projections refer to the process of transforming geographic data from one 

Coordinate Reference System (CRS) to another. 

→ It is important because different GIS datasets may be in different CRSs, and when 

overlaying or analyzing them, they need to be in the same CRS to ensure accurate 

results. 

→ There are various types of projections, each with different properties and 

distortions. QGIS supports multiple projections, allowing users to work with spatial 

data in different coordinate systems based on their needs. 
 

Steps to Project Data in QGIS: 
 

1. Launch the QGIS application on your computer. 

2. Add the layers you want to project into QGIS. 

3. Go to the "Project" menu in the menu bar and select "Properties". Here, you can see 

the CRS of the layer. 

4. Set the CRS you want to project to. 

5. Apply the changes and save the project. 
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7.3. Output 
 

1. Added a vector layer ne_10m_admin_0_countries.shp file; Before projection 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Selecting appropriate projection from CRS. 
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4. Resultant output after Projection: 
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Lab 8: Nearest neighbor Analysis 
 

8.1. Objectives 
 

- Learn about Nearest Neighbor Analysis and its application in GIS. 

- Understand the steps involved in performing Nearest Neighbor Analysis in QGIS, 

including loading layers, removing null values, and calculating distances to the 

nearest hub. 

 

8.2. Theory 
 

Nearest Neighbor Analysis 
 

Nearest Neighbor analysis is a spatial analysis technique used in GIS to identify the closest 

features to each feature in a dataset. This analysis is particularly useful for understanding 

spatial patterns, clustering, and relationships within a dataset. 

 

Steps to Perform Nearest Neighbor Analysis: 
 

1. Load the input layer and the reference layer into QGIS. 

i. Add Vector Layer → (ne_10m_populated_places_simple.shp). 

ii. Add Delimited Text Layer by keep the settings as custom → 

(earthquakes_2021_11_25_14_31_59_+0530.tsv) 

2. Remove Null Values: 

i. Go to 'Processing' (in the processing toolbox) → Toolbox → Vector 

Geometry → Remove Null Geometry. 

ii. Specify the layer to remove null geometries 

(earthquakes_2021_11_25_14_31_59_+0530.tsv). 

iii. Give the layer a name. 

iv. Allocate a file location to save the layer. 

v. A non-null geometry layer will be added. You can now remove the original 

earthquake layer. 

3. Perform Distance to Nearest Hub: 

i. Search for "Distance to Nearest Hub" in the processing toolbox. 

ii. Select the source point layer (eq-non-null geometry). 

iii. Select the destination hub (ne_10m_populated_places_simple.shp). 

iv. Select the "Hub layer name attribute" → abc: name. (if default value is left 

then it will display number instead of name.) 

v. Choose the "Measurement unit" → Kilometers. 

vi. In hub distance, allocate a file location and name (NearestHubDistance) to 

save the result. 

vii. Click 'Run'. 

viii. A new layer will be added displaying the distance to the nearest hub. 

By following these steps, you can perform a Nearest Neighbor analysis using QGIS 

software to identify spatial relationships within your dataset. 
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8.3. Output 
 

1. Added a vector and a delimited text layer: ne_10m_populated.shp and earthquakes.tsv. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Removing the null values. 
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3. Selecting only those layers with non-null data. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Calculating distance to nearest hub (line to hub). 
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5. Resultant Output: 
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Lab 9: Spatial joins 
 

9.1. Objectives 
 

- Learn how to perform Spatial Join and Point in Polygon Analysis in GIS. 

- Understand the steps involved in combining attributes based on spatial relationships 

and conducting spatial analysis. 

- Gain proficiency in loading vector layers, setting parameters, and interpreting 

analysis results in QGIS. 

 

9.2. Theory 
 

Spatial Join 
 

Spatial joins are used to combine attributes from one layer to another based on their spatial 

relationship. 

 

Spatial joins are a GIS operation used to combine information from two spatial datasets 

based on their spatial relationships. In a spatial join, attributes from one dataset are 

appended to another dataset based on the spatial relationship between their geometries 

(points, lines, or polygons). 

 
Steps to Perform Spatial Join: 

 

1. Load the vector layers (local_unit.shp & waterways.shp) in your GIS software. 

2. Go to the Processing Toolbox, search for "Join Attributes by Location" and click it. 

OR, navigate to 'Vector' in the menu bar → Data Management Tools → Join 

Attributes by Location. 

3. Set the following parameters: 

i. Join features in: local_unit 

ii. Features to add: intersect 

iii. By comparing to: waterways 

iv. Fields to add: all 

v. Join type: one to one (type of spatial relationship) 

vi. Provide a name (joined) and location for the joined layer to save. 

vii. Click 'Run'. 

4. The output will be a new layer containing attributes from both layers based on the 

specified spatial relationship. 

5. Display only the joined layer. 

6. Right-click on the joined layer and select `Show Labels`. 

7. The names of rivers will be displayed. 

 
Steps to Perform Point in Polygon Analysis: 
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1. Load the required vector layer (ne_10m_admin_0_countries.shp) and delimited text 

layer (earthquakes_2021_11_25_14_31_59_+0530.tsv). 

2. Go to the Processing Toolbox, search for "Count Points in Polygon" and click it. 

OR, navigate to 'Vector' in the menu bar → Analysis Tools → Count Points in 

Polygon. 

3. Set the required parameters: 

i. Polygons: ne_10m_admin_0_countries 

ii. Points: earthquakes_2021_11_25_14_31_59_+0530 

iii. Provide a name (countpoints) and location for the output layer to save. 

iv. Click 'Run'. 

4. A new count layer will be created. 

5. To locate Nepal's data, zoom in to Nepal and select it. 
 
 
 

9.3. Output 
 

1. Added two vector layers: local_unit.shp and waterways.shp. (Before joining attributes) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Joining Attributes by Location. 
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3. Resultant Output: 
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4. Attribute table of joined layer. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9.4. Output 
 

1. Loaded a vector and delimited text layer ne_10m_admin_countries.shp earthquake.tsv. 
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2. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Count the number of points in polygon. 
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4. Resultant Output: Showing number of points in Nepal. 
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Lab 10: Python in QGIS (PyQGIS) 
 

10.1. Objectives 
 

- I 
 

10.2. Theory 
 

Python in QGIS (PyQGIS) 
 

→ PyQGIS refers to the use of the Python programming language to extend the 

functionality of QGIS. 

→ Python scripting allows users to automate tasks, customize workflows, and perform 

advanced spatial analysis within the QGIS environment. 

 

Spatial Data: 
 

→ It refers to data that is associated with specific geographic locations or positions on 

the Earth's surface. 

→ It includes information about the shape, size, location, and attributes of spatial 

features such as points, lines, and polygons. 
 

Data Processing: 
 

→ It involves the manipulation, transformation, and analysis of spatial data to extract 

meaningful information. 

 

Python Scripting: 
 

→ It involves writing and executing Python code to automate tasks, perform 

calculations, and manipulate data within the QGIS environment. 

→ Open QGIS and go to "Plugins" → "Python Console" to access the Python scripting 

environment. 

→ By utilizing Python scripting in QGIS, users can enhance their workflows and 

perform complex spatial analyses efficiently. 

 

Python Console: 
 

→ The QGIS Python Console is an interactive shell for executing Python commands. 

→ It also has a Python file editor that allows you to edit and save your Python scripts. 

→ Both the console and editor are based on the PyQScintilla2 package. 
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Find and display the maximum and minimum area using python. 
 

# Import necessary modules from PyQGIS 

from qgis.core import QgsVectorLayer, QgsProject 
 

# Define the path to your shapefile 

shapefile_path = 

r"C:\Users\prati\OneDrive\Desktop\shape_files_of_districts_in_nepal.shp" 
 

# Load the shapefile 

layer = QgsVectorLayer(shapefile_path, "Layer Name", "ogr") 
 

# Check if the layer was loaded successfully 

if not layer.isValid(): 

print("Layer failed to load!") 

else: 

# Add the layer to the QGIS project 

QgsProject.instance().addMapLayer(layer) 

print("Layer loaded successfully!") 
 

# Get the fields in the layer 

fields = layer.fields() 

# Assuming the field you want to find min and max for is named 'your_field_name' 

field_name = 'Area' 
 

# Get index of the field 

field_index = fields.indexFromName(field_name) 
 

# Initialize variables for min and max values 

min_value = float('inf') 

max_value = float('-inf') 
 

# Iterate over features to find min and max values 

for feature in layer.getFeatures(): 

# Get the attribute value of the field 

attribute_value = feature.attributes()[field_index] 

# Check if the value is numeric 

if attribute_value is not None and isinstance(attribute_value, (int, float)): 

min_value = min(min_value, attribute_value) 

max_value = max(max_value, attribute_value) 
 

# Print the min and max values 

print("Minimum value:", min_value) 

print("Maximum value:", max_value) 
 

# Refresh the QGIS interface 

iface.layerTreeView().refreshLayerSymbology(layer.id()) 
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10.3. Output 
 

1. Python code and output in Python Console of QGIS. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Attribute Table: Displaying area field from maximum to minimum values. 
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3. Attribute Table: Displaying area field from minimum to maximum values 
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Lab 11: Sampling raster data using points 
 

11.1. Objectives 
 

- Learn how to sample raster data using points in QGIS. 

- Perform zonal statistics analysis to calculate statistics within specified zones. 

- Adjust layer properties for zonal statistics visualization, including symbology and 

labeling. 
 

11.2. Theory 
 

Raster data provides a representation of the world as a regular grid, divided into an array 

of cells where each cell has an associated value. 

 
Zonal statistics are useful for comparing zones and assessing trends over time across 

various geographical regions. They provide a convenient way to monitor progress. 

 

Performing Zonal Statistics: 
 

1. Load the required raster layer (us.tmax_nohads_ll_20140525_float.tif). 

2. Load the required delimited text layer (2013_Gaz_ua_national.txt) containing point 

coordinates. 

i. In the Point Coordinates section: 

• Set "X Field" to 'INTPTLAT'. 

• Set "Y Field" to 'INTPTLONG'. 

ii. Add the layer. 

3. Go to 'Processing' → Processing Toolbox, and search for "Zonal Statistics" and 

click it. 

4. In the Zonal Statistics tool: 

i. Browse and select the appropriate shapefile (tl_2018_us_county.shp). 

ii. Set "Statistics to calculate" to 'Mean'. 

iii. Give a name and location for the output file (zonal statistics) to save the 

layer. 

iv. Click 'Run'. 

5. The output will be a new layer containing statistical information calculated within 

specified zones. In this case, since the statistics to calculate is set to Mean, the 

output will provide the mean value of the raster data within each zone defined by 

the shapefile (tl_2018_us_county.shp). This means that for each zone (county), the 

output will include the average value of the raster data. 

6. Adjust Layer Properties for the crated layer. 

i. Right-click on the "Zonal Statistics" layer and go to `Properties`. 

ii. Go to the 'Label' tab and set the labeling mode to 'Single Label'. 

iii. Go to the `Symbology` tab, choose 'Graduated', and set 'Value' to the output 

field from zonal statistics (here, "outputmean"). 

iv. Click 'Classify'. 
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v. Click 'Apply' and then 'OK'. 
 
 
 

11.3. Output 
 

1. Added raster and delimited text layer: us.tmax_nohads_ll_20140525_float.tif and 

2013_Gaz_ua_national.txt. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Calculating zonal statistics of raster layer. 
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3. . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Resultant Output: 
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Lab 12: USGS Earth Explorer 
 

12.1. Objectives 
 

- Learn how to search, download, and manage geographic datasets from the USGS 

Earth Explorer. 

- Learn techniques for merging multiple raster datasets into a single comprehensive 

file. 

 

12.2. Theory 
 

USGS Earth Explorer 
 

The USGS Earth Explorer is a web-based application that allows users to search, download, 

and view geographic datasets, including satellite imagery, aerial photographs, and 

topographic maps. It is widely used by researchers, scientists, and GIS professionals for 

various applications such as environmental monitoring, land use planning, and disaster 

management. 

 
Steps to Merge: 

 

1. Visit the USGS Earth Explorer website. 

2. Register your account and then login to the website. 

3. Select the area of a particular country or city that you want to merge. 

4. Go to the "Data Sets" tab and click on "Landsat → Landsat Collection 2 Level-2 → 

Landsat 8-9 OLI/TIRS C2 L2." 

5. Click on the "Results." 

6. Download at least four datasets that appear as results in 'TIF' format. 

7. Open QGIS software. 

8. Go to Layer → Add Layer → Add Raster Layer. 

9. Add all the downloaded data. 

10. Go to Raster → Miscellaneous → Merge. 

11. Save the file, and you will get the merged data. 
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12.3. Output 
 

1. Select any geographical area. 
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2. Download the required dataset. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Load the raster layers. 
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4. Merge the raster layers. 
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Lab 13: Interpolating point Data 
 

13.1. Objectives 
 

- Perform TIN interpolation on point data to create a continuous surface in QGIS. 

- Clip the interpolated raster to a specified boundary. 

- Generate and customize contour lines from the clipped raster. 
 

13.2. Theory 
 

By following the below steps, you will successfully interpolate point data, clip the resulting 

raster by a mask layer, and generate contour lines with appropriate properties in QGIS. 

 
Spatial Interpolation 

 

Spatial interpolation is a method used in geographic information systems (GIS) to estimate 

unknown values at specific locations based on known values at surrounding locations. The 

primary goal of spatial interpolation is to create a continuous surface from discrete point 

data, allowing for better visualization, analysis, and decision-making. 

 
Methods of Interpolation 

 

1. Inverse Distance Weighting (IDW) 

2. Triangular Irregular Network (TIN) 

 
TIN 

 

The Triangular Irregular Network (TIN) method creates a surface of contiguous, non-

overlapping triangles from known data points using Delaunay triangulation, ensuring 

nearly equilateral triangles. It is ideal for irregularly spaced data and is commonly used in 

terrain modeling. TIN preserves exact data points and handles irregular spacing well, but it 

can be computationally intensive for large datasets. 

 
Perform TIN Interpolation: 

 

1. Load the required vector layers. (Islands_2004_550_stpl83, 

Boundary_2004_550_stpl83 and Arlington_Soundings_2007_stpl83) 

2. For TIN Interpolation, open the Processing Toolbox and search for "TIN 

Interpolation". 

3. In the TIN Interpolation tool set the parameters: 

i. Vector layer: 'Arlington' and Interpolation attribute: 'Elevation' then click 

on add button. Do the same for 'Islands' layer. 

ii. Interpolation: linear 

iii. Extent: Calculate from layer → Boundary. 

iv. Pixel size Y: 5. 

v. Interpolated: Provide a file name and save the output. 
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vi. Click `Run`. 

4. The interpolation will be generated. Customize the properties if needed. 
 

Clip Raster by Mask Layer 
 

1. For Clipping Raster by Mask Layer, open the Processing Toolbox, and search for 

"Clip Raster by Mask Layer". 

2. Set the parameters: 

a. Input layer: Select the interpolated raster layer. 

b. Mask layer: Select 'Boundary'. 

c. Provide a location and name to the file to save the output. 

d. Click 'Run'. 

3. The clipped raster will be generated. Customize the properties if needed. 
 

Generate Contours 
 

1. For generating contours, open the Processing Toolbox and search for "Contour" 

(Raster Extraction Contour). 

2. Set the parameters: 

a. Input: Select the clipped raster layer. 

b. Band number: Use the default band number. 

c. Interval between contour lines: 10 

d. Provide a location and name to the file to save the output. 

e. Click 'Run'. 

3. The contour lines layer will be generated. 

4. Customize the layer properties: 

a. Label: Single 

b. Value: Set to the elevation file name. 

c. Placement: Curved 

d. Click 'Apply'. 
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13.3. Output 
 

1. Loaded respective vector layers (.shp files). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Performing TIN Interpolation. 
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3. Interpolated Layer: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Clipping interpolated raster layer by mask. 
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5. Clipped raster layer: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Generating Contour Lines: 
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7. Customizing Contour Properties: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. Resultant Contour Lines: 
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Lab 14: Batch processing using processing framework 
 

14.1. Objectives 
 

- Learn to dissolve vector layers based on a specified attribute field. 

- Practice exporting selected features from a vector layer. 

- Perform batch processing of vector overlay operations to clip multiple layers 

efficiently. 

 

14.2. Theory 
 

Batch Processing 
 

Batch processing in GIS refers to the automation of repetitive geoprocessing tasks across 

multiple datasets. Instead of manually applying a geoprocessing tool to each dataset 

individually, batch processing allows users to define the operation once and apply it to all 

datasets in a single execution. This approach significantly enhances efficiency and ensures 

consistency across processed data. 

 
By following the given below steps, you will efficiently use batch processing to perform 

dissolve and clip operations on multiple layers, and customize the resulting layers in QGIS. 

 

Steps to Dissolve layer: 
 

1. Load the vector layer (ne_10m_admin_0_countries.shp). 

2. For dissolving layer, open the Processing Toolbox and search for " Dissolve". OR, 

in the menu bar, go to 'Vector' → Geoprocessing Tools → 'Dissolve'. 

3. In the Dissolve tool set the parameters: 

i. Input layer: ne_10m_admin_0_countries.shp. 

ii. Dissolve field: Continent. 

iii. Click 'Run'. 
 

Steps to Export Selected Features: 
 

1. Use the "Select features by" icon on the toolbar. 

2. Select the desired features. 

3. Right-click on the layer and choose 'Export' → Save Selected Features As. 

i. Provide a location and name to the file to save the output. 

ii. Click 'OK'. 
 

Steps for Batch Processing with Vector Overlay: 
 

1. Open the Processing Toolbox and search for "Vector overlay". 

2. Find and right-click on "Clip" → Execute as batch process. 

3. In the batch processing dialog, set: 
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i. Input layer: Browse and select the shapefiles for 'airports', 'ports', and 

'railways'. 

ii. Overlay layer: Select the newly created layer from the dissolve operation 

using "select feature". 

iii. Clipped: Browse and select the file location to save each clipped output. 

4. In the Autofill menu: 

i. Set Autofill mode: Fill with parameter values 

ii. Check on 'Load layer on completion'. 

iii. Click 'Run'. 

5. Once the batch process is complete, you can customize the properties of the newly 

created layers. 

6. To show labels on layers: 

i. Right-clicking on a respective layer. 

ii. Go to 'Properties' → Labels. 

iii. Set 'Label' → Single Labels. 

iv. Choose the appropriate field for the label. 

v. Click 'Apply' and 'OK'. 

 
 
 
 

14.3. Output 
 

1. Loaded the vector layer `ne_10m_admin_0_countries.shp`. 
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2. Dissolving continent field from the vector layer. 
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3. Layer generated after dissolving continent field. 
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4. Exporting selected feature: Africa continent. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Saving the selected feature to be exported as a vector layer. 
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6. A new vector layer named 'africa' has been added to the project. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. Vector Overlay Clip Operations on Multiple Layers (Batch Processing). 
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8. Resultant clipped layers: 
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